All Discussions Tagged 'head' (27)

Discussions Replies Latest Activity

Roland SP-540i no black no cyan

Hello, my Roland Sp 540i has an issue. After replacing head 1, the printer isnt showing any black and cyan. Yellow and Magenta is performi…

Started by rick koole

3 Nov 3
Reply by rick koole

Print head leaking? VS300

Hey Guys, Would just like some input as to what you may think is the cause to the below. When doing a manual clean the print head drips i…

Started by Nicholas Watson

6 Oct 16
Reply by irving donaldson

Roland vs-540 print head replacement

I just want to know if it is hard to change the print head on a Roland vs-540 The local shop is asking for $3000 to replace it, I found the…

Started by rudy uribe

2 Oct 2
Reply by rudy uribe

BN-20 PrintHead Replacement?

I have a BN-20.   I love my machine.  But now the print quality on the black ink side is not so good... actually is sucks.   Its a lot of s…

Started by Kevin Van Middlesworth

4 Aug 30
Reply by Kevin Van Middlesworth

Black Nozzles Clogged on BN-20

Aloha Everyone, I stumbled upon this forum, and it is AWESOME!  I am hoping to get some help from all the experts on here.  I really need…

Started by Alan Joaquin

13 Aug 6
Reply by Eugene Galochkin

Roland VP540 blowing fuse F1 repeatedly

Hi everyone, I  just joined this forum - it seems like a great place for resources on our industry and im very excited to be part of it. …

Started by Fred

9 Apr 28
Reply by Fred

sp300 head unlock - power off

Hi, I have pwr off at the sub and the main switch, attempted to move the head right so that it unlocks and I can slide the head away from t…

Started by james bones

10 Jan 4
Reply by james bones

Strange white dots on print! Help!!

Hi,I have been pulling my hair out over this. Ok, so I have 2x soljet pro3 xc540 machines.One machine runs bulk inks, the other runs carts.…

Started by Stephen Graham

8 Sep 28, 2016
Reply by Stephen Graham

Strange lines appearing in middle of prints! Xc-540

Hi again all, I have a strange one for you. XC-540. After a good run of say 20m, i started noticing strange lines appearing in the middle o…

Started by Stephen Graham

3 Jul 13, 2016
Reply by Stephen Graham

XC-540 MAGENTA Half Firing and woes..

Hi folks, I had an engineer replace the cyan head as it was banding. In the process he showed me the cable connecting to the head one of th…

Started by Stephen Graham

4 Jul 10, 2016
Reply by Stephen Graham

RSS

© 2017   Created by Steven Jackson - Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service